in WAMPServer

Correcting WAMPServer Apache problems

A long time ago, I had the WAMPServer application set up on a netbook and did some WordPress work on that setup. Since then, I have moved on to a full laptop, but had not used WAMPServer on that machine. I wanted a place to explore some different WordPress themes separate from my regular install, so I started on the WAMP install process.

I downloaded the current version at the time and clicked through the install steps, which were pretty straightforward. However, when I started WAMPServer and tried to enter “localhost” in the browser, I did not see the default PHP index page. After some searching in the WAMPServer forums, I found that if Skype is installed, that can tie up port 80. I tried unchecking the box for port 80 in Skype options in my installation, but still did not see anything when I entered localhost in the browser. Finally, per this Wampserver forum post, I saw that it should be possible to change the Apache port to port 8080 instead of 80. I edited httpd.conf (at C:\wamp\bin\apache\Apache2.4.4\conf in my install) and changed the port listening to 8080 as follows:

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 8080

After that, http://localhost:8080 worked! The WAMPServer documentation should be updated to make it easier to correct this problem.

Write a Comment

Comment

  1. thank u very much sir .. I really appreciate your effort in writing this blog .. It doesn’t directly hit my problem but it gives me an idea on how to resolve it.